解决Composer因php_openssl扩展缺失而安装失败的问题

Composer是PHP下的一个依赖管理工具。你可以在你的项目中声明你所需要用到的类库,然后Composer会在项目中为你安装它们。如果你了解Node的 npm 或者Ruby的 Bundler ,就理解它是做什么的了,但是,它不是包管理器。

在Windows的Wamp环境下安装Composer(注:Composer要求PHP版本在5.3.2+),你可能会遇到这种安装失败的情况:出错信息是 “The openssl extension is missing, which will reduce the security and stability of Composer. If possible you should enable it or recompile php with –with-openssl” 表示你的PHP环境缺少openssl扩展。

如果使用的Wamp集成环境,你可能会去屏幕右下角的Wamp的控制台,去加载php的openssl扩展,或者在php.ini中去掉 extension=php_openssl.dll 这一行开头的注释,然后重启server,结果发现还是不行。

正确的做法是在php的安装目录比如说C:\wamp\bin\php\php5.4.12\中,找到找个目录下的php.ini文件,然后去掉 extension=php_openssl.dll 这一行开头的注释,之后就可以顺利安装Composer了。

你可以发现上面出现了两个php.ini,是的Wamp在Apache和在CLI(命令行)模式下使用了不同的php.ini文件,当你在WAMP的控制台去启用php_openssl这个扩展,是启用的Apache的,而非CLI。而修改php安装目录中的php.ini配置文件,则可以启用CLI模式下的openssl。

转载请注明来源:新一 » 解决Composer因php_openssl扩展缺失而安装失败的问题

赞 (2) 评论 (0) 分享 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址